Android, Obsolescence ProgrammĂ©e 

Rappel que si votre application Android favorite n'est plus supportée parce que vous êtes sur une version trop vieille d'Android, c'est bien davantage la faute du constructeur du téléphone¹ et de Google² que celle du ou de la dévelopeur·euse.

re: Android, Obsolescence ProgrammĂ©e 

¹ Qui ne fait souvent pas l'effort de donner des mises à jour au delà de deux ans, et ne libère pas les sources des noyaux "custom" pour leurs appareils, rendant le travail des contributeur·ices de projets comme LinaageOS bien plus complexe.

Show thread

re: Android, Obsolescence ProgrammĂ©e 

² Google qui fait bien peu d'efforts pour encourager les constructeurs à maintenir leurs appareils plus longtemps.

Show thread
Follow

re: Android, Obsolescence ProgrammĂ©e 

Pour rappel,

  • Android < 5 ne supporte pas ou mal TLS 1.2
  • Les certificats Let's Encrypt ne seront plus supportĂ©s sur Android < 7.1.1 Ă  compter de septembre 2021.
· · Web · 1 · 3 · 1

re: Android, Obsolescence ProgrammĂ©e 

@tcit ça va faire très très mal letsencrypt pas supporté :/

re: Android, Obsolescence ProgrammĂ©e 

@amdg2 Absolument, c'est pas impossible que le secteur de la vente de certificats bénéficie d'une seconde jeunesse.

re: Android, Obsolescence ProgrammĂ©e 

@tcit est-ce Google et les principaux constructeurs de smartphones se fendrait d'un patch comme Microsoft pour Windows XP avec WannaCry 🤔
ça serait surprenant, mais cool.

re: Android, Obsolescence ProgrammĂ©e 

@amdg2 Je ne vois pas trop ça arriver.

Sign in to participate in the conversation
Mastodon by tcit

This is my personal Mastodon server, with a few extra people on it.